suggest change
class Example {
    void method(boolean error) {
        if (error) {
            Log.error("Error occurred!");
        } else { // Use braces since the other block uses braces.
            System.out.println("No error");

Short forms

enum Response { YES, NO, MAYBE }
public boolean isReference() { return true; }

The above recommendations are intended to improve uniformity (and thus increase familiarity / readability). In some cases “short forms” that deviate from the above guidelines are just as readable and may be used instead. These cases include for instance simple enum declarations and trivial methods and lambda expressions.

Feedback about page:

Optional: your email if you want me to get back to you:

Table Of Contents